Contents
Top Next

HeartSuite XP Document Template Codes
Version 1.1

All Patient Clinical Exams
All Patient Echoes
Catheter
Catheter Come In
Catheter Days
Catheter Days Last Month
Catheter Days Last Six Months
Catheter Days Last Year
Catheter Waiting List
CCAD
Courses
Current Inpatients
Current Inpatients ITU
Current Inpatients Ward 11
Current Inpatients Ward 12
Death
Diagnosis
Drugs
Echocardiogram
Follow Up
GP
Had surgery last month
Had surgery this month
Had surgery two months ago
Inpatient Stay
Last ECG
Last Echocardiogram
Last Inpatient Stay
Liaison Nurse
MRI
MRI Waiting List
On Catheter Waiting List
On Catheter Waiting List Short Notice
On Surgical Waiting List
On Surgical Waiting List Short Notice
Outpatient Clinic/Consultation
Patient Codes
Patient Inpatient Stays
Patient Procedures
Surgery
Surgery Cancelled For the Rest of the Month
Surgery Cancelled Last Month
Surgery Cancelled Next Month
Surgery Cancelled This Month
Surgery for next month
Surgery for the rest of the month
Surgery for this month
Surgery last month
Surgical Discharges from last month
Surgical Discharges from this month
Surgical Discharges from two months ago
Surgical Referral list
System Codes


All Patient Clinical Exams
Previous Top Next

Returns data for all of the Clinical Examinations/Outpatient Consultations for the current patient in a list. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

##allpatientcexams.date_id## | Returns all of the dates on which the patient has had a consultation
##allpatientcexams.height## | All of the height measurements entered
##allpatientcexams.weight## |
##allpatientcexams.bsa## |
##allpatientcexams.seen_by## | Consultants initials
##allpatientcexams.source## | Code for source
##allpatientcexams.symptoms## |
##allpatientcexams.nhya## |
##allpatientcexams.hb## |
##allpatientcexams.appt_date## |
##allpatientcexams.appt_time## |
##allpatientcexams.start## |
##allpatientcexams.end## |
##allpatientcexams.bp## | Blood pressures
##allpatientcexams.bpla## |
##allpatientcexams.bprl## |
##allpatientcexams.bpll## |
##allpatientcexams.additional_info## |
##allpatientcexams.summary## |
##allpatientcexams.findings## |
##allpatientcexams.saturations## |


All Patient Echoes

Returns data for all of the Echocardiograms for the current patient in a list. You may wish to put the codes within a table to ensure that data for each echo lines up properly.
##allpatientechoes.date_id## | Returns all of the dates on which the patient has had an echo
##allpatientechoes.reason## |
##allpatientechoes.findings## |
##allpatientechoes.operator1## | Operators initials
##allpatientechoes.operator2## |
##allpatientechoes.tape## |
##allpatientechoes.disk## |
##allpatientechoes.observations## |
##allpatientechoes.Doppler_comment## |
##allpatientechoes.findings## |
##allpatientechoes.reported_by## | Initials
##allpatientechoes.copy_report## |


Catheter

Returns the details of a particular Catheter. Used for the Catheter report called from the button on the Catheter screen.
##cath.type## |
##cath.total_contrast## |
##cath.longage## | The patient's age in years and months
##cath.cathnumber## |
##cath.height## |
##cath.weight## |
##cath.bsa## |
##cath.haem## |
##cath.conference_conclusion## |
##cath.conference_text## |
##cath.rad_dose## |
##cath.videonumber## |
##cath.operator1## |
##cath.operator2## |
##cath.operator3## |
##cath.technician## |
##cath.anaesthetist## |
##cath.scribed_by## |
##cath.anaesthesia## |
##cath.enter## |
##cath.exit## |
##cath.procedure_time## |
##cath.screen_time## |
##cath.duration## |
Approach Grid |
##cath.approach## | Lists all approaches entered
##cath.vessel## | Lists the vessels
##cath.maxf## | Lists all of the max French sizes
Purpose Grids |
##cath.phaem## | Lists purpose type
##cath.pimage## | Lists imaging
##cath.pinterven## | Lists interventions
##cath.achievehaem## | Achieved yes/no
##cath.achieveimage## | Achieved yes/no
##cath.achieveinterven## | Achieved yes/no
1##cath.complications## | Lists the complications
##cath.procedures## | Lists procedures
##cath.proc_details## |
Pressure and O2 Sat Grid |
##cath.po2site## | Lists the sites
##cath.po2sat## | Lists the saturations
##cath.po2a## | List
##cath.po2v## | List
##cath.po2sys## | List
##cath.po2dias## | List
##cath.po2edp## | List
##cath.po2mean## | List
##cath.po2pstat## | List
Gradients Grid |
##cath.gradfrom## | List
##cath.gradpullfrom## | List
##cath.gradsimulfrom## | List
##cath.gradto## | List
##cath.gradpullto## | List
##cath.gradsimulto## | List
##cath.gradcath## | List
##cath.gradtype## | List
##cath.gradpp## | List
##cath.gradpullpp## | List
##cath.gradsimuldiff## | List
##cath.gradpstat## | List
Calculations Grid |
##cath.calc1site## | List
##cath.calc1o2sat## | List
##cath.calc1hb## | List
##cath.calc1po2## | List
##cath.calc1o2source## | List
##cath.calc1o2content## | List
##cath.calc1meanp## | List
##cath.calc1pstatus## | List
##cath.calc1qpqs## | QPQS
##cath.calc1rprs## | RPRS
##cath.calc1lrshunt## | LR Shunt
##cath.calc1qp## | QP
##cath.calc1rp## | RP
##cath.calc1qs## | QS
##cath.calc1rs## | RS
##cath.calc1perlrshunt## | % LR Shunt
Angiography Grid |
##cath.angiosite## | List
##cath.angiovol## | List of Volumes
##cath.angiocontrast## | List of contrasts
##cath.angioproject1## | List of projection1's
##cath.angioproject2## | List of projections2's
##cath.angioreport## |
##cath.diagnosis## | List of diagnoses for this patient
##cath.last_echo_tape## | Most recent echo tape before date of the catheter


Catheter Come In

A list of all patients who have a come in date on their Catheter Waiting list but who have not yet been catheterised. Patients are sorted by their come in date followed by the date of their catheter except in Birmingham where they are sorted by who referred them and then by come in date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##cathcomein.title## | Can be used to specify whether the report is for 10 days. Returns nothing for a full report.
##cathcomein.referral_date## |
##cathcomein.referred_by## |
##cathcomein.come_in## | Come in date
##cathcomein.ga_required## | Returns yes, no or n/a
##cathcomein.extra_info## |
##cathcomein.intervention## |
##cathcomein.cath_date## |
##cathcomein.name## | The patient's forename and surname
##cathcomein.pdiagnosis## | The patient's primary diagnosis or 'Not yet entered' if they do not have one
##cathcomein.shortpdiagnosis## | The first 45 characters of patient's primary diagnosis or 'Not yet entered' if they do not have one
##cathcomein.dob## | The patients date of birth
##cathcomein.post_code## | The patient's post code
##cathcomein.longage## | The patient's age in the form e.g. 2 years 6 months. If the patient is dead then their date of death is shown
##cathcomein.mediumage## | The patient's age in the form e.g. 2 y 6 m. If the patient is dead then their date of death is shown
##cathcomein.working_diagnosis## |
##cathcomein.patient_id## | Patients hospital number


Catheter Days

A list of all patients who have a come in date on their Catheter Waiting list but who have not yet been catheterised. Patients are sorted by their come in date followed by the date of their catheter except in Birmingham where they are sorted by who referred them and then by come in date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.
##cathcomein.title## | Can be used to specify whether the report is for 10 days. Returns nothing for a full report.
##cathcomein.referral_date## |
##cathcomein.referred_by## |
##cathcomein.come_in## | Come in date
##cathcomein.ga_required## | Returns yes, no or n/a
##cathcomein.extra_info## |
##cathcomein.intervention## |
##cathcomein.cath_date## |
##cathcomein.name## | The patient's forename and surname
##cathcomein.pdiagnosis## | The patient's primary diagnosis or 'Not yet entered' if they do not have one
##cathcomein.shortpdiagnosis## | The first 45 characters of patient's primary diagnosis or 'Not yet entered' if they do not have one
##cathcomein.dob## | The patients date of birth
##cathcomein.post_code## | The patient's post code
##cathcomein.longage## | The patient's age in the form e.g. 2 years 6 months. If the patient is dead then their date of death is shown
##cathcomein.mediumage## | The patient's age in the form e.g. 2 y 6 m. If the patient is dead then their date of death is shown
##cathcomein.working_diagnosis## |
##cathcomein.patient_id## | Patients hospital number


Catheter Days Last Month

Gets all the catheters for the last month and returns details of the Inpatient stays during the time of those catheters as well as the number of ITU and ward days. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##cathdayslastmonth.date_of_cath## |
##cathdayslastmonth.date_of_birth## |
##cathdayslastmonth.patient_id## | Patients hospital number
##cathdayslastmonth.id## | Patients hospital number
##cathdayslastmonth.name## | The patients name
##cathdayslastmonth.totaldays## | The total days of the inpatient stay when the catheter was done
##cathdayslastmonth.itudays## | The number of itu days of the inpatient stay when the catheter was done
##cathdayslastmonth.hddays## | The number of high dependancy days of the inpatient stay when the catheter was done
##cathdayslastmonth.warddays## | The number of ward days of the inpatient stay when the catheter was done
##cathdayslastmonth.admit_date## | The admission date fo the inpatient stay
##cathdayslastmonth.discharge_date## | The discharge date
##cathdayslastmonth.procedure1## | The first 60 characters of primary procedures during this stay


Catheter Days Last Six Months

Gets all the catheters for the last eighteen months and returns details of the Inpatient stays during the time of those catheters as well as the number of ITU and ward days. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##cathdayslastsixmonths.date_of_cath## |
##cathdayslastsixmonths.date_of_birth## |
##cathdayslastsixmonths.patient_id## | Patients hospital number
##cathdayslastsixmonths.id## | Patients hospital number
##cathdayslastsixmonths.name## | The patients name
##cathdayslastsixmonths.totaldays## | The total days of the inpatient stay when the catheter was done
##cathdayslastsixmonths.itudays## | The number of itu days of the inpatient stay when the catheter was done
##cathdayslastsixmonths.hddays## | The number of high dependancy days of the inpatient stay when the catheter was done
##cathdayslastsixmonths.warddays## | The number of ward days of the inpatient stay when the catheter was done
##cathdayslastsixmonths.admit_date## | The admission date fo the inpatient stay
##cathdayslastsixmonths.discharge_date## | The discharge date
##cathdayslastsixmonths.procedure1## | The first 60 characters of primary procedures during this stay


Catheter Days Last Year

Gets all the catheters for the last year and returns details of the Inpatient stays during the time of those catheters as well as the number of ITU and ward days. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##cathdayslastyear.date_of_cath## |
##cathdayslastyear.date_of_birth## |
##cathdayslastyear.patient_id## | Patients hospital number
##cathdayslastyear.id## | Patients hospital number
##cathdayslastyear.name## | The patients name
##cathdayslastyear.totaldays## | The total days of the inpatient stay when the catheter was done
##cathdayslastyear.itudays## | The number of itu days of the inpatient stay when the catheter was done
##cathdayslastyear.hddays## | The number of high dependancy days of the inpatient stay when the catheter was done
##cathdayslastyear.warddays## | The number of ward days of the inpatient stay when the catheter was done
##cathdayslastyear.admit_date## | The admission date fo the inpatient stay
##cathdayslastyear.discharge_date## | The discharge date
##cathdayslastyear.procedure1## | The first 60 characters of primary procedures during this stay


Catheter Waiting List

These codes return the details of a particular Catheter Waiting List. Commonly used for the generation of catheter TCI letters.

##cathwl.appointment_sent## |
##cathwl.cath_date## | Proposed catheter date
##cathwl.come_in## |
##cathwl.exit_from_wl## |
##cathwl.referral_date## |
##cathwl.urgency_revision_date## |
##cathwl.longappointment_sent## | Date in a long form e.g. 5th of April 2002
##cathwl.longcath_date## |
##cathwl.longcome_in## |
##cathwl.longexit_from_wl## |
##cathwl.longreferral_date## |
##cathwl.longurgency_revision_date## |
##cathwl.catheter_performed## | Returns Yes No or Unknown
##cathwl.ga_required## | Returns Yes No or Unknown
##cathwl.exit_time_from_referral## |
##cathwl.extra_info_details## |
##cathwl.revision_comment## |
##cathwl.haemodynamic## |
##cathwl.imaging## |
##cathwl.intervention## |
##cathwl.referred_by## |
##cathwl.reason_for_exit## |
##cathwl.type## |
##cathwl.urgency## |
##cathwl.urgency_revision## |
##cathwl.reop_sequence## |
##cathwl.consultant## | Consultant responsible for the procedure
##cathwl.reop_text## |
##cathwl.ccad## | Returns a list of European codes for the catheter
##cathwl.euro## | Returns a list of European codes for the catheter
##cathwl.ccadpp## |
##cathwl.europp## |
##cathwl.ccad_proc## | Returns all of the procedures for that catheter for this waiting list
##cathwl.ccad_comments## | Returns the catheter conference
##cathwl.ccad_consultant## | Looks to operator 1 and 2 and tries to return a consultant
##cathwl.ccad_opgrade## | Returns the CCAD code for op grade. No longer used
##cathwl.cath_weight## | Finds data from the catheter for this waiting list record
##cathwl.procedure_time## | Finds data from the catheter for this waiting list record
##cathwl.screen_time## | Finds data from the catheter for this waiting list record
##cathwl.rad_dose## | Radiation Dose. Finds data from the catheter for this waiting list
##cathwl.cath_date_id## | Finds data from the catheter for this waiting list record
##cathwl.admit_date## | Admit date for the catheter for this waiting list record
##cathwl.discharge_date## | Discharge date for the catheter for this waiting list record
##cathwl.preproc_seizures## |
##cathwl.postproc_seizures## | Finds data from the catheter for this waiting list record
##cathwl.repeat_procedure## | Finds data from the catheter for this waiting list record
##cathwl.preproc_pcpc## | Finds data from the catheter for this waiting list record
##cathwl.postproc_pcpc## | Finds data from the catheter for this waiting list record
##cathwl.benchmark## | Finds data from the catheter for this waiting list record
Previous Procedures | Codes that pertain to procedures done prior to this catheter
##cathwl.prevproc_date_id## | A list of the dates of previous procedures
##cathwl.prevproc_description## | List describing what procedures were done.
##cathwl.prevproc_ccad## | Returns a list of the European codes for previous procedures
##cathwl.prevproc_ccadpp## | Returns a list of the European codes for previous procedures
##cathwl.prevproc_europp## | Returns a list of the European codes for previous procedures
##cathwl.ccad_status## | Returns the CCAD status field


CCAD

The following codes may be used on CCAD Approval forms. Templates that use these codes must be tied to a specific procedure i.e. accessed through a button within the system

Pertaining to Waiting List data |
##ccad.referral_date## |
##ccad.referral_received## |
##ccad.accepted_for_surgery## |
##ccad.discharge_date## |
##ccad.appointment_sent## |
##ccad.come_in## |
##ccad.planned_op_date## |
##ccad.exit_from_wl## |
##ccad.longreferral_date## | The following dates are displayed in a long form e.g. 15th March 2001
##ccad.longreferral_recieved## |
##ccad.longaccepted_for_surgery## |
##ccad.longdischarge_date## |
##ccad.longappointment_sent## |
##ccad.longcome_in## |
##ccad.longplanned_op_date## |
##ccad.longexit_from_wl## |
##ccad.referred_by## |
##ccad.referred_to## |
##ccad.patient_category## |
##ccad.suggested_procedure## |
##ccad.condition## |
##ccad.blood_checked## |
##ccad.teeth_inspection## |
##ccad.referral_letter## | Return Yes or No
##ccad.surgery_performed## |
##ccad.scsr## | A Scottish Cardiac Surgery Number
##ccad.urgency## |
##ccad.actual_urgency## |
##ccad.previous_bypass## |
##ccad.previous_closed## |
##ccad.time_from_referral## |
##ccad.procedure_required1## |
##ccad.procedure_required2## |
##ccad.blood_group## |
##ccad.comment## |
##ccad.wlsurgeon## |
##ccad.exit_reason## |
##ccad.disposal## |
Codes specific to surgical episodes |
##ccad.surgery_where## | Unique to Birmingham
##ccad.complications## | Lists all of the complications for this procedure
##ccad.surgical_procedures## | Lists all the surgical procedures for this episode and their complexity
##ccad.shortsurgical_procedures## | Lists all the surgical procedures for this episode
##ccad.date_id## | 'Date of surgery attached to waiting list
##ccad.height## |
##ccad.weight## |
##ccad.BSA## |
##ccad.haem## |
##ccad.surgeon## |
##ccad.anaesthetist## |
##ccad.assistant1## |
##ccad.assistant2## |
##ccad.diagnosis_notes## |
##ccad.surgery_no## |
##ccad.total_cpb_time## |
##ccad.total_aoclamptime## |
##ccad.total_circulatoryarrest_time## |
##ccad.duration_ippv## |
##ccad.preproc_seizures## |
##ccad.postproc_seizures## |
##ccad.repeat_procedure## |
##ccad.repeat_incision## |
##ccad.preproc_pcpc## |
##ccad.postproc_pcpc## |
##ccad.sternotomy_sequence## |
##ccad.details## |
##ccad.findings## |
##ccad.cardiacdiagnosis## | Lists cardiac diagnoses for the patient with their ICD10 code
##ccad.shortcardiacdiagnosis## | Lists cardiac diagnoses for the patient


Courses

These codes are used to access the information held in the Courses screen.

##patientcourses.datespokento##
##patientcourses.suit1##
##patientcourses.attend1##
##patientcourses.suit2##
##patientcourses.attend2##
##patientcourses.suit3##
##patientcourses.attend3##
##patientcourses.suit3##
##patientcourses.attend4##
##patientcourses.suit4##
##patientcourses.notes##
##patientcourses.course1##
##patientcourses.course2##
##patientcourses.course3##
##patientcourses.course4##


Current Inpatients

These codes return lists of details pertaining to all of the current inpatients. Inpatients are defined as patients with an admission date but no corresponding discharge date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##currentinpatients.id## | Hospital Number
##currentinpatients.name## | Patients forename and surname
##currentinpatients.date_of_birth## | Patients date of birth
##currentinpatients.consultant## | That the patient is under
##currentinpatients.ward## | That the patient is currently in
##currentinpatients.working_diagnosis## |
##currentinpatients.latest_procedure## | The most recent procedure recorded for the patient


Current Inpatients ITU

Current Inpatients ITU

These codes return lists of details pertaining to all of the current inpatients who are recorded as being in the ITU at the time the document is created. Inpatients are defined as patients with an admission date but no corresponding discharge date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##currentinpatientsitu.id## | Hospital Number
##currentinpatientsitu.name## | Patients forename and surname
##currentinpatientsitu.date_of_birth## | Patients date of birth
##currentinpatientsitu.consultant## | That the patient is under
##currentinpatientsitu.ward## | That the patient is currently in
##currentinpatientsitu.working_diagnosis## |
##currentinpatientsitu.latest_procedure## | The most recent procedure recorded for the patient


Current Inpatients Ward 11

Specific to Birmingham these codes return lists of details pertaining to all of the current inpatients who are recorded as being in ward 11 at the time the document is created. Inpatients are defined as patients with an admission date but no corresponding discharge date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##currentinpatientsw11.id## | Hospital Number
##currentinpatientsw11.name## | Patients forename and surname
##currentinpatientsw11.date_of_birth## | Patients date of birth
##currentinpatientsw11.consultant## | That the patient is under
##currentinpatientsw11.ward## | That the patient is currently in
##currentinpatientsw11.working_diagnosis## |
##currentinpatientsw11.latest_procedure## | The most recent procedure recorded for the patient


Current Inpatients Ward 12

Specific to Birmingham these codes return lists of details pertaining to all of the current inpatients who are recorded as being in ward 12 at the time the document is created. Inpatients are defined as patients with an admission date but no corresponding discharge date. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##currentinpatientsw12.id## | Hospital Number
##currentinpatientsw12.name## | Patients forename and surname
##currentinpatientsw12.date_of_birth## | Patients date of birth
##currentinpatientsw12.consultant## | That the patient is under
##currentinpatientsw12.ward## | That the patient is currently in
##currentinpatientsw12.working_diagnosis## |
##currentinpatientsw12.latest_procedure## | The most recent procedure recorded for the patient


Death

Codes to return details entered into the Death Screen

##death.cause_of_death## |
##death.location## | Location code for where the death occurred
##death.pm_report## |
##death.audit_discussion## |


Diagnosis

Codes to return diagnosis details for a patient

##diagnosis.primary## | Gives the description and ICD10 code for the patients primary diagnosis
##diagnosis.cardiac## | Lists all cardiac diagnoses
##diagnosis.cardiacpop## | Lists postop status for each diagnoses
##diagnosis.cardiacccad## | Lists all european diagnoses codes
##diagnosis.cardiacicd10## | Lists all ICD10 diagnoses codes
##diagnosis.noncardiac## | Lists non cardiac diagnoses
##diagnosis.noncardiacpop## | Lists postop status for each non cardiac diagnoses
##diagnosis.noncardiacccad## | Lists European codes for non cardiac diagnoses
##diagnosis.noncardiacicd10## | Lists ICD10 codes for non cardiac diagnoses
##diagnosis.list## | Lists descriptions of all diagnoses


Drugs

Codes to return a list of the current drug data for the patient. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##drugs.date_id## |
##drugs.drug## |
##drugs.dose## |
##drugs.dose_units## |
##drugs.dose_and_units## | Both together
##drugs.frequency## |
##drugs.duration## |
##drugs.form## |
##drugs.drug_form## |


Echocardiogram

Codes to return echocardiogram details for a patient

##echo.disk## |
##echo.tape## |
##echo.consultant## |
##echo.cooperation## |
##echo.findings## |
##echo.site1## | Doppler site
##echo.site1measure## |
##echo.site14v2## |
##echo.site2## |
##echo.site2measure## |
##echo.site24v2## |
##echo.site3## |
##echo.site3measure## |
##echo.site34v2## |
##echo.site4## |
##echo.site4measure## |
##echo.site44v2## |
##echo.site5## |
##echo.site5measure## |
##echo.site54v2## |
##echo.site6## |
##echo.site6measure## |
##echo.site64v2## |
##echo.site7## |
##echo.site7measure## |
##echo.site74v2## |
##echo.doppler_comment## |
##echo.fetal## |
##echo.interoperative## |
##echo.location## |
##echo.observations## |
##echo.operator1## |
##echo.operator2## |
##echo.quality## |
##echo.reason## |
##echo.reported_by## |
##echo.routine_echo## |
##echo.source## |
##echo.tapetime## |
##echo.toe## |
##echo.2dcolour## |
##echo.lvot## |
##echo.rvot## |
##echo.aoarch## |
##echo.atseptum## |
##echo.vseptum## |
##echo.arduct## |
##echo.inrange_rvd## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_lvd## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_lvs## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_vs## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_pw## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_la## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_aor## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_lvef## | Returns an asterix in if the field is outwith the normal range
##echo.inrange_lvfs## | Returns an asterix in if the field is outwith the normal range
##echo.copy_report## |
##echo.category## |
##echo.stroke_volume## |


Follow Up

Codes to return a list of the follow up data for the patient. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##followup.where##
##followup.time##
##followup.date##


GP

Codes to return details of the patient's GP.

##gp.name## | The GP's name
##gp.healthcentre## | The first line of his address
##gp.address## | The GP's forename, Surname and then address in a label format
##gp.1lineaddress## | The GP's forename, surname and address all on 1 line
##gp.surname## | GP's surname
##gp.telephone## | GP's telephone no


Had surgery last month

Gets all the surgery entered during the last month and returns a list of details for the patients and the surgery. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##hadsurglastmonth.nameandaddress## | Name and address of the patient in a label format
##hadsurglastmonth.admit_date## | The admission date of the episode when the surgery was done
##hadsurglastmonth.date_id## | Date of the surgery
##hadsurglastmonth.discharge_date## | The disposal date from the waiting list
##hadsurglastmonth.dob## | Date of birth for the patient
##hadsurglastmonth.patient_id## | Patient's hospital number
##hadsurglastmonth.pprocedure## | The primary procedure
##hadsurglastmonth.shortpdiagnosis## | The first 35 characters of the primary procedure
##hadsurglastmonth.scsr## |
##hadsurglastmonth.suggested_procedure## | From the Waiting List
##hadsurglastmonth.condition## | From the Waiting List
##hadsurglastmonth.ptype## | Type of the primary procedure
##hadsurglastmonth.surgeon## |


Had surgery this month

Gets all the surgery entered this month and returns a list of details for the patients and the surgery. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##hadsurgthismonth.nameandaddress## | Name and address of the patient in a label format
##hadsurgthismonth.admit_date## | The admission date of the episode when the surgery was done
##hadsurgthismonth.date_id## | Date of the surgery
##hadsurgthismonth.discharge_date## | The disposal date from the waiting list
##hadsurgthismonth.dob## | Date of birth for the patient
##hadsurgthismonth.patient_id## | Patient's hospital number
##hadsurgthismonth.pprocedure## | The primary procedure
##hadsurgthismonth.shortpdiagnosis## | The first 35 characters of the primary procedure
##hadsurgthismonth.scsr## |
##hadsurgthismonth.suggested_procedure## | From the Waiting List
##hadsurgthismonth.condition## | From the Waiting List
##hadsurgthismonth.ptype## | Type of the primary procedure
##hadsurgthismonth.surgeon## |


Had surgery two months ago

Gets all the surgery entered for the last two months and returns a list of details for the patients and the surgery. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##hadsurg2monthsago.nameandaddress## | Name and address of the patient in a label format
##hadsurg2monthsago.admit_date## | The admission date of the episode when the surgery was done
##hadsurg2monthsago.date_id## | Date of the surgery
##hadsurg2monthsago.discharge_date## | The disposal date from the waiting list
##hadsurg2monthsago.dob## | Date of birth for the patient
##hadsurg2monthsago.patient_id## | Patient's hospital number
##hadsurg2monthsago.pprocedure## | The primary procedure
##hadsurg2monthsago.shortpdiagnosis## | The first 35 characters of the primary procedure
##hadsurg2monthsago.scsr## |
##hadsurg2monthsago.suggested_procedure## | From the Waiting List
##hadsurg2monthsago.condition## | From the Waiting List
##hadsurg2monthsago.ptype## | Type of the primary procedure
##hadsurg2monthsago.surgeon## |


Inpatient Stay

Returns details of a specific inpatient stay. Must be accessed from the inpatient stay record. Used for immediate discharge summary.

##inpatientstay.admit_consultant## | Admitting consultant
##inpatientstay.admit_consultant_speciality## |
##inpatientstay.discharge_consultant## |
##inpatientstay.discharge_consultant_speciality## |
##inpatientstay.admit_date## |
##inpatientstay.admit_ward## |
##inpatientstay.discharge_date## |
##inpatientstay.stay_sentence## | Builds a sentence based on the inpatient stay in the form 'patient's name was admitted under the care of consultant on admit date and discharged under the care of consultant on discharge date'
##inpatientstay.pcardiac_diagnosis## | Primary cardiac diagnosis
##inpatientstay.coded_pcardiac_diagnosis## | As above but with ICD10 code
##inpatientstay.cardiac_diagnosis## | All of the cardiac diagnoses
##inpatientstay.coded_cardiac_diagnosis## | As above with ICD10 codes
##inpatientstay.related_cardiac_diagnosis## | Cardiac diagnoses without the primary
##inpatientstay.coded_related_cardiac_diagnosis## | As above with ICD10 codes
##inpatientstay.noncardiac_diagnosis## | All noncardiac diagnoses
##inpatientstay.coded_noncardiac_diagnosis## | As above with ICD10 codes
##inpatientstay.admit_reason## |
##inpatientstay.admit_type## |
##inpatientstay.discharge_to## |
##inpatientstay.procedures## | During this episode
##inpatientstay.cprocedures## | Catheter procedures during this admission
##inpatientstay.cproceduresopcs4## | The OPCS4 codes for procedures during this admission
##inpatientstay.cproceduresccad## | CCAD codes for procedures during this admission
##inpatientstay.cproceduresdate## | The dates of catheter procedures during this admission
##inpatientstay.cproceduresoperator## | The operator1's of catheter procedures during this admission
##inpatientstay.sprocedures## | Surgical procedures during this admission
##inpatientstay.sproceduresopcs4## | As above with OPCS4 codes
##inpatientstay.sproceduresdate## | The date(s) of surgical procedures during this admission
##inpatientstay.sproceduresoperator## | The surgeon(s)
##inpatientstay.previous_procedures## |
##inpatientstay.problems_during_admission## | List
##inpatientstay.problems_on_discharge## | List
##inpatientstay.itudays## | ITU days during this admission
##inpatientstay.hddays## | High Dependancy days during this admission
##inpatientstay.warddays## | Ward days during this admission
##inpatientstay.totaldays## | Total days of this admission


Last ECG

Returns details of the last ECG done on the patient.
##lastecg.operator1## |
##lastecg.operator2## |
##lastecg.consultant## |
##lastecg.date_id## | Date of the last ECG
##lastecg.source## | Source Code
##lastecg.location## | Location Code
##lastecg.ecg_report## |
##lastecg.ett_report## |
##lastecg.event_report## |
##lastecg.bpmonitor_report## |
##lastecg.holter_report## |
##lastecg.purpose## |
##lastecg.ecg_no## |
##lastecg.ett_reason## |
##lastecg.ett_medication1## |
##lastecg.ett_medication2## |
##lastecg.ett_medication3## |
##lastecg.ett_method## |
##lastecg.ett_protocol## |
##lastecg.ett_rest_ecg## |
##lastecg.ett_rest_ecg_abn## |
##lastecg.ett_heart_rest## |
##lastecg.ett_heart_peak## |
##lastecg.ett_heart_pred85## |
##lastecg.ett_heart_pred100## |
##lastecg.ett_bp_rest## |
##lastecg.ett_bp_peak## |
##lastecg.ett_bp_fall## |
##lastecg.ett_bp_exercise## |
##lastecg.ett_duration## |
##lastecg.ett_percentage## |
##lastecg.ett_recovery## |
##lastecg.ett_stage## |
##lastecg.ett_stage_comment## |
##lastecg.ett_workload## |
##lastecg.ett_motivation## |
##lastecg.ett_outcome## |
##lastecg.ett_stop_main## |
##lastecg.ett_stop_secondary## |
##lastecg.ecg_attending_doc## |
##lastecg.ecg_time## |
##lastecg.ecg_disk## |
##lastecg.ecg_category## |
##lastecg.ecg_copy_report## |
##lastecg.ecg_pri_reason## |
##lastecg.ecg_2nd_reason## |
##lastecg.ecg_rhythm## |
##lastecg.ecg_changes## |
##lastecg.ecg_heart_rate## |
##lastecg.ecg_pr_interval## |
##lastecg.ecg_qrsaxis## |
##lastecg.ecg_qrsduration## |
##lastecg.ecg_qt## |


Last Echocardiogram

Returns details of the last Echo done on the patient. Unlike the echo codes many will return the code rather than the text of the lookup.

##lastecho.disk## |
##lastecho.tape## |
##lastecho.consultant## |
##lastecho.cooperation## |
##lastecho.findings## |
##lastecho.site1## | Doppler site
##lastecho.site1measure## |
##lastecho.site14v2## |
##lastecho.site2## |
##lastecho.site2measure## |
##lastecho.site24v2## |
##lastecho.site3## |
##lastecho.site3measure## |
##lastecho.site34v2## |
##lastecho.site4## |
##lastecho.site4measure## |
##lastecho.site44v2## |
##lastecho.site5## |
##lastecho.site5measure## |
##lastecho.site54v2## |
##lastecho.site6## |
##lastecho.site6measure## |
##lastecho.site64v2## |
##lastecho.site7## |
##lastecho.site7measure## |
##lastecho.site74v2## |
##lastecho.doppler_comment## |
##lastecho.fetal## |
##lastecho.interoperative## |
##lastecho.location## |
##lastecho.observations## |
##lastecho.operator1## |
##lastecho.operator2## |
##lastecho.quality## |
##lastecho.reason## |
##lastecho.reported_by## |
##lastecho.routine_echo## |
##lastecho.source## |
##lastecho.tapetime## |
##lastecho.toe## |
##lastecho.2dcolour## |
##lastecho.lvot## |
##lastecho.rvot## |
##lastecho.aoarch## |
##lastecho.atseptum## |
##lastecho.vseptum## |
##lastecho.arduct## |
##lastecho.inrange_rvd## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_lvd## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_lvs## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_vs## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_pw## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_la## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_aor## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_lvef## | Returns an asterix in if the field is outwith the normal range
##lastecho.inrange_lvfs## | Returns an asterix in if the field is outwith the normal range
##lastecho.copy_report## |
##lastecho.category## |
##lastecho.stroke_volume## |


Last Inpatient Stay

Returns details of the last inpatient stay the patient had.

##lastinpatientstay.admit_consultant## | Admitting consultant
##lastinpatientstay.admit_consultant_speciality## |
##lastinpatientstay.discharge_consultant## |
##lastinpatientstay.discharge_consultant_speciality## |
##lastinpatientstay.admit_date## |
##lastinpatientstay.admit_ward## |
##lastinpatientstay.discharge_date## |
##lastinpatientstay.stay_sentence## | Builds a sentence based on the inpatient stay in the form ##patient's name was admitted under the care of consultant on admit date and discharged under the care of consultant on discharge date
##lastinpatientstay.pcardiac_diagnosis## | Primary cardiac diagnosis
##lastinpatientstay.coded_pcardiac_diagnosis## | As above but with ICD10 code
##lastinpatientstay.cardiac_diagnosis## | All of the cardiac diagnoses
##lastinpatientstay.coded_cardiac_diagnosis## | As above with ICD10 codes
##lastinpatientstay.related_cardiac_diagnosis## | Cardiac diagnoses without the primary
##lastinpatientstay.coded_related_cardiac_diagnosis## | As above with ICD10 codes
##lastinpatientstay.noncardiac_diagnosis## | All noncardiac diagnoses
##lastinpatientstay.coded_noncardiac_diagnosis## | As above with ICD10 codes
##lastinpatientstay.admit_reason## |
##lastinpatientstay.admit_type## |
##lastinpatientstay.discharge_to## |
##lastinpatientstay.procedures## | During this episode
##lastinpatientstay.cprocedures## | Catheter procedures during this admission
##lastinpatientstay.cproceduresopcs4## | The OPCS4 codes for procedures during this admission
##lastinpatientstay.cproceduresccad## | CCAD codes for procedures during this admission
##lastinpatientstay.cproceduresdate## | The dates of catheter procedures during this admission
##lastinpatientstay.cproceduresoperator## | The operator1's of catheter procedures during this admission
##lastinpatientstay.sprocedures## | Surgical procedures during this admission
##lastinpatientstay.sproceduresopcs4## | As above with OPCS4 codes
##lastinpatientstay.sproceduresdate## | The date(s) of surgical procedures during this admission
##lastinpatientstay.sproceduresoperator## | The surgeon(s)
##lastinpatientstay.previous_procedures## |
##lastinpatientstay.problems_during_admission## | List
##lastinpatientstay.problems_on_discharge## | List
##lastinpatientstay.itudays## | ITU days during this admission
##lastinpatientstay.hddays## | High Dependancy days during this admission
##lastinpatientstay.warddays## | Ward days during this admission
##lastinpatientstay.totaldays## | Total days of this admission


Liaison Nurse

These codes return details of a specific liaison nurse consultation and therefore can only be used in the templates accessed by buttons on the Liaison Nurse screen.

##liaison.consultant## |
##liaison.cardiologist## |
##liaison.surgery## |
##liaison.seen_by## |
##liaison.location## |
##liaison.ref_type## |
##liaison.cons_type## |
##liaison.present## |
##liaison.purpose## |
##liaison.orientation## |
##liaison.info_given## |
##liaison.outcome## |
##liaison.followup## |
##liaison.reason## |
##liaison.info## | List
##liaison.info_details## | List
##liaison.allother_date_id## | List relating to all of the other liaison consultations done on this patient
##liaison.allother_type## | List relating to all of the other liaison consultations done on this patient
##liaison.allother_present## | List relating to all of the other liaison consultations done on this patient
##liaison.allother_seen_by## | List relating to all of the other liaison consultations done on this patient
##liaison.action## | List
##liaison.action_details## | List
##liaison.date_completed## | List


MRI

These codes return details of a specific MRI and therefore can only be used in the templates accessed by buttons on the MRI screen.


MRI Waiting List

These codes return details of a specific MRI List Entry and therefore can only be used in the templates accessed by buttons on the MRI Waiting List screen.


On Catheter Waiting List

Used to give data on all patients on the Catheter Waiting List defined as those who have a catheter waiting list record without a date in the exit_from_wl field. Patients may be grouped by urgency. You may wish to put the codes within a table to ensure that data for each waiting list lines up properly.

To show all |
##oncathwl.referral_date## | List
##oncathwl.referred_by## | List
##oncathwl.come_in## | List
##oncathwl.ga_required## | List
##oncathwl.extra_info## | List
##oncathwl.intervention## | List
##oncathwl.cath_date## | List
##oncathwl.name## | List patients forename and surname
##oncathwl.pdiagnosis## | List of patients primary diagnosis
##oncathwl.shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.dob## | List of patients date of birth
##oncathwl.longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.working_diagnosis## | List
##oncathwl.patient_id## | List of hospital numbers
##oncathwl.title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show urgent patients |
##oncathwl.u:referral_date## | List
##oncathwl.u:referred_by## | List
##oncathwl.u:come_in## | List
##oncathwl.u:ga_required## | List
##oncathwl.u:extra_info## | List
##oncathwl.u:intervention## | List
##oncathwl.u:cath_date## | List
##oncathwl.u:name## | List patients forename and surname
##oncathwl.u:pdiagnosis## | List of patients primary diagnosis
##oncathwl.u:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.u:dob## | List of patients date of birth
##oncathwl.u:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.u:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.u:working_diagnosis## | List
##oncathwl.u:patient_id## | List of hospital numbers
##oncathwl.u:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show routine patients |
##oncathwl.r:referral_date## | List
##oncathwl.r:referred_by## | List
##oncathwl.r:come_in## | List
##oncathwl.r:ga_required## | List
##oncathwl.r:extra_info## | List
##oncathwl.r:intervention## | List
##oncathwl.r:cath_date## | List
##oncathwl.r:name## | List patients forename and surname
##oncathwl.r:pdiagnosis## | List of patients primary diagnosis
##oncathwl.r:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.r:dob## | List of patients date of birth
##oncathwl.r:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.r:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.r:working_diagnosis## | List
##oncathwl.r:patient_id## | List of hospital numbers
##oncathwl.r:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show deferred patients |
##oncathwl.d:referral_date## | List
##oncathwl.d:referred_by## | List
##oncathwl.d:come_in## | List
##oncathwl.d:ga_required## | List
##oncathwl.d:extra_info## | List
##oncathwl.d:intervention## | List
##oncathwl.d:cath_date## | List
##oncathwl.d:name## | List patients forename and surname
##oncathwl.d:pdiagnosis## | List of patients primary diagnosis
##oncathwl.d:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.d:dob## | List of patients date of birth
##oncathwl.d:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.d:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.d:working_diagnosis## | List
##oncathwl.d:patient_id## | List of hospital numbers
##oncathwl.d:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show emergency patients |
##oncathwl.e:referral_date## | List
##oncathwl.e:referred_by## | List
##oncathwl.e:come_in## | List
##oncathwl.e:ga_required## | List
##oncathwl.e:extra_info## | List
##oncathwl.e:intervention## | List
##oncathwl.e:cath_date## | List
##oncathwl.e:name## | List patients forename and surname
##oncathwl.e:pdiagnosis## | List of patients primary diagnosis
##oncathwl.e:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.e:dob## | List of patients date of birth
##oncathwl.e:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.e:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.e:working_diagnosis## | List
##oncathwl.e:patient_id## | List of hospital numbers
##oncathwl.e:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show unclassified patients i.e. those with no urgency entered |
##oncathwl.x:referral_date## | List
##oncathwl.x:referred_by## | List
##oncathwl.x:come_in## | List
##oncathwl.x:ga_required## | List
##oncathwl.x:extra_info## | List
##oncathwl.x:intervention## | List
##oncathwl.x:cath_date## | List
##oncathwl.x:name## | List patients forename and surname
##oncathwl.x:pdiagnosis## | List of patients primary diagnosis
##oncathwl.x:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwl.x:dob## | List of patients date of birth
##oncathwl.x:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwl.x:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwl.x:working_diagnosis## | List
##oncathwl.x:patient_id## | List of hospital numbers
##oncathwl.x:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only


On Catheter Waiting List Short Notice

Used to give data on all patients on the Catheter Waiting List defined as those who have a catheter waiting list record without a date in the exit_from_wl field who have their short notice field set. Patients may be grouped by urgency. You may wish to put the codes within a table to ensure that data for each waiting list lines up properly.

To show all |
##oncathwlshortnotice.referral_date## | List
##oncathwlshortnotice.referred_by## | List
##oncathwlshortnotice.come_in## | List
##oncathwlshortnotice.ga_required## | List
##oncathwlshortnotice.extra_info## | List
##oncathwlshortnotice.intervention## | List
##oncathwlshortnotice.cath_date## | List
##oncathwlshortnotice.name## | List patients forename and surname
##oncathwlshortnotice.pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.dob## | List of patients date of birth
##oncathwlshortnotice.longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.working_diagnosis## | List
##oncathwlshortnotice.patient_id## | List of hospital numbers
##oncathwlshortnotice.title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show urgent patients |
##oncathwlshortnotice.u:referral_date## | List
##oncathwlshortnotice.u:referred_by## | List
##oncathwlshortnotice.u:come_in## | List
##oncathwlshortnotice.u:ga_required## | List
##oncathwlshortnotice.u:extra_info## | List
##oncathwlshortnotice.u:intervention## | List
##oncathwlshortnotice.u:cath_date## | List
##oncathwlshortnotice.u:name## | List patients forename and surname
##oncathwlshortnotice.u:pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.u:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.u:dob## | List of patients date of birth
##oncathwlshortnotice.u:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.u:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.u:working_diagnosis## | List
##oncathwlshortnotice.u:patient_id## | List of hospital numbers
##oncathwlshortnotice.u:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show routine patients |
##oncathwlshortnotice.r:referral_date## | List
##oncathwlshortnotice.r:referred_by## | List
##oncathwlshortnotice.r:come_in## | List
##oncathwlshortnotice.r:ga_required## | List
##oncathwlshortnotice.r:extra_info## | List
##oncathwlshortnotice.r:intervention## | List
##oncathwlshortnotice.r:cath_date## | List
##oncathwlshortnotice.r:name## | List patients forename and surname
##oncathwlshortnotice.r:pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.r:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.r:dob## | List of patients date of birth
##oncathwlshortnotice.r:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.r:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.r:working_diagnosis## | List
##oncathwlshortnotice.r:patient_id## | List of hospital numbers
##oncathwlshortnotice.r:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show deferred patients |
##oncathwlshortnotice.d:referral_date## | List
##oncathwlshortnotice.d:referred_by## | List
##oncathwlshortnotice.d:come_in## | List
##oncathwlshortnotice.d:ga_required## | List
##oncathwlshortnotice.d:extra_info## | List
##oncathwlshortnotice.d:intervention## | List
##oncathwlshortnotice.d:cath_date## | List
##oncathwlshortnotice.d:name## | List patients forename and surname
##oncathwlshortnotice.d:pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.d:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.d:dob## | List of patients date of birth
##oncathwlshortnotice.d:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.d:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.d:working_diagnosis## | List
##oncathwlshortnotice.d:patient_id## | List of hospital numbers
##oncathwlshortnotice.d:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show emergency patients |
##oncathwlshortnotice.e:referral_date## | List
##oncathwlshortnotice.e:referred_by## | List
##oncathwlshortnotice.e:come_in## | List
##oncathwlshortnotice.e:ga_required## | List
##oncathwlshortnotice.e:extra_info## | List
##oncathwlshortnotice.e:intervention## | List
##oncathwlshortnotice.e:cath_date## | List
##oncathwlshortnotice.e:name## | List patients forename and surname
##oncathwlshortnotice.e:pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.e:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.e:dob## | List of patients date of birth
##oncathwlshortnotice.e:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.e:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.e:working_diagnosis## | List
##oncathwlshortnotice.e:patient_id## | List of hospital numbers
##oncathwlshortnotice.e:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only
To show unclassified patients i.e. those with no urgency entered |
##oncathwlshortnotice.x:referral_date## | List
##oncathwlshortnotice.x:referred_by## | List
##oncathwlshortnotice.x:come_in## | List
##oncathwlshortnotice.x:ga_required## | List
##oncathwlshortnotice.x:extra_info## | List
##oncathwlshortnotice.x:intervention## | List
##oncathwlshortnotice.x:cath_date## | List
##oncathwlshortnotice.x:name## | List patients forename and surname
##oncathwlshortnotice.x:pdiagnosis## | List of patients primary diagnosis
##oncathwlshortnotice.x:shortpdiagnosis## | List of patients primary diagnosis. Only the first 45 characters are shown
##oncathwlshortnotice.x:dob## | List of patients date of birth
##oncathwlshortnotice.x:longage## | List of patient ages in the form e.g. 5 years 6 months
##oncathwlshortnotice.x:mediumage## | List of patient ages in the form e.g. 5 y 6 m
##oncathwlshortnotice.x:working_diagnosis## | List
##oncathwlshortnotice.x:patient_id## | List of hospital numbers
##oncathwlshortnotice.x:title## | Used on reports tied to a specific consultant e.g. For Dr John Smith only


On Surgical Waiting List

Used to give data on all patients on the Surgical Waiting List defined as those who have a surgical waiting list record without a date in the exit_from_wl field ordered by their come in date. You may wish to put the codes within a table to ensure that data for each waiting list lines up properly.

##onsurgwl.come_in## | List
##onsurgwl.planned_op_date## | List
##onsurgwl.referral_date## | List
##onsurgwl.blood_group## | List
##onsurgwl.ward## | List
##onsurgwl.blood_quantity## | List
##onsurgwl.scsr## | List
##onsurgwl.surgeon## | List
##onsurgwl.procedures_required## | List
##onsurgwl.procedure_types## | List
##onsurgwl.suggested_procedure## | List
##onsurgwl.condition## | List
##onsurgwl.name## | List of patients, forename and surname
##onsurgwl.pdiagnosis## | List of primary diagnosis
##onsurgwl.dob## | List of patients dates of birth
##onsurgwl.working_diagnosis## | List
##onsurgwl.patient_id## | List
##onsurgwl.centre## | List
##onsurgwl.attended_clinic## | List
##onsurgwl.attended## | List
##onsurgwl.comment## | List
##onsurgwl.daysonwl## | List


On Surgical Waiting List Short Notice

Used to give data on all patients on the Surgical Waiting List defined as those who have a catheter waiting list record without a date in the exit_from_wl field ordered by their come in date who have their short notice field set. You may wish to put the codes within a table to ensure that data for each waiting list lines up properly.

##onsurgwlshortnotice.come_in## | List
##onsurgwlshortnotice.planned_op_date## | List
##onsurgwlshortnotice.referral_date## | List
##onsurgwlshortnotice.blood_group## | List
##onsurgwlshortnotice.ward## | List
##onsurgwlshortnotice.blood_quantity## | List
##onsurgwlshortnotice.scsr## | List
##onsurgwlshortnotice.surgeon## | List
##onsurgwlshortnotice.procedures_required## | List
##onsurgwlshortnotice.procedure_types## | List
##onsurgwlshortnotice.suggested_procedure## | List
##onsurgwlshortnotice.condition## | List
##onsurgwlshortnotice.name## | List of patients, forename and surname
##onsurgwlshortnotice.pdiagnosis## | List of primary diagnosis
##onsurgwlshortnotice.dob## | List of patients dates of birth
##onsurgwlshortnotice.working_diagnosis## | List
##onsurgwlshortnotice.patient_id## | List
##onsurgwlshortnotice.centre## | List
##onsurgwlshortnotice.attended_clinic## | List
##onsurgwlshortnotice.attended## | List
##onsurgwlshortnotice.comment## | List
##onsurgwlshortnotice.daysonwl## | List


Outpatient Clinic/Consultation

Codes to return details entered into the Outpatient Clinic/Consultation screen. They are generally used to populate the documents in the Letters Tab. These codes only work when accessed from the screen as they relate to a specific clinic/consultation.

##opc.symptoms## |
##opc.additional_info## |
##opc.findings## |
##opc.summary## |
##opc.source## |
##opc.consultant## |
##opc.seen_by## |
##opc.date_id## |
##opc.height## |
##opc.weight## |
##opc.nyha## |
##opc.hb## |
##opc.appt_date## | Appointment date
##opc.appt_time## | Appointment Time
##opc.bp## | Blood Pressures
##opc.bpla## |
##opc.bprl## |
##opc.bpll## |
##opc.saturations## |


Patient Codes

These codes are used to access the general patient information including all of the information in the Admin screen.
##patient.date_of_death## |
##patient.date_of_birth## |
##patient.date_of_birth_day## | Returns the day from the date of birth
##patient.date_of_birth_month## | Returns the month from the date of birth
##patient.date_of_birth_year## | Returns the year from the date of birth
##patient.sex## |
##patient.address## | The full patient address in a label format
##patient.1lineaddress## | The full patient address on one line
##patient.1lineaddressnopcode## | The full patient address on one line without the post code
##patient.1linech## | The Child Health contact and their address on one line
##patient.1linechother## | The other contact details from the admin screen on one line
##patient.1lineothercorrespondant## | The other correspondent details from the admin screen on one line
##patient.hv_address## | The Health Visitors address
##patient.pdn_address## | The Paediatric district nurse address
##patient.he/she## | Returns he for a male, she for a female. Defaults to he
##patient.capshe/she## | Returns He for a male, She for a female. Defaults to He
##patient.his/her## | Returns his for a male, her for a female. Defaults to his
##patient.capshis/her## | Returns His for a male, Her for a female. Defaults to His
##patient.boy/girl## | Returns boy for male, girl for female. Defaults to boy.
##patient.telephone## | Patients telephone number
##patient.endocarditus_prophylaxis## |
##patient.action_on_ga## |
##patient.immunisations## |
##patient.activity## |
##patient.fetal_diagnosis## |
##patient.longage## | In the form e.g. 5 years 6 months
##patient.consultant## |
##patient.name## | Forename and surname
##patient.forename## |
##patient.surname## |
##patient.working_diagnosis## |
##patient.dentist_address## | In a label form
##patient.birth_weight## |
##patient.birth_weightlbsoz## | In the form e.g. 10lbs 3 ozs
##patient.maiden_name## |
##patient.next_of_kin## |
##patient.nhs_number## |
##patient.ethnicity## |
##patient.paediatrician## | Their full name including salutation
##patient.shortpaediatrician## | A shorter name e.g. Dr Smith
##patient.paed_address## | Paediatrician's address in a label format
##patient.hospital## | The local hospital
##patient.hospitaladdress## | The local hospital address in a label format
##patient.1linehospitaladdress## | The local hospital address on one line
##patient.hospital2## |
##patient.hospitaladdress2## | In a label format
##patient.1linehospitaladdress2## | On one line
##patient.hospital3## |
##patient.hospitaladdress3## | In a label format
##patient.1linehospitaladdress3## | On one line
##patient.vitamink## |
##patient.age## | As a real number
##patient.marital_status## | The code
##patient.relationship## | The code
##patient.mobile## | Patients mobile number
##patient.health_board## | The health board or health authority code
##patient.surgeon## | As specified on the admin screen
##patient.allergy_details## |
##patient.memo## | The text that appears in the memo box for the patient when they are accessed
##patient.midwife## |
##patient.work_telephone## |
##patient.social_history## |
##patient.nok2## | Name of second next of kin
##patient.nok2_address1## | Address of second next of kin line 1
##patient.nok2_address2## | Address of second next of kin line 2
##patient.nok2_address3## | Address of second next of kin line 3
##patient.nok2_post_code## | Post code of second next of kin
##patient.nok2_telephone## | Telephone number of second next of kin
##patient.nok2_mobile## | Mobile number of second next of kin
##patient.nok2_work_telephone## | Work telephone of second next of kin


Patient Inpatient Stays

These codes are used to give details of all of the inpatient stays for a particular patient. You may wish to put the codes within a table to ensure that data lines up properly.

##patientinpatientstay.admit_consultant## | List
##patientinpatientstay.discharge_consultant## | List
##patientinpatientstay.admit_reason## | List
##patientinpatientstay.admit_date## | List
##patientinpatientstay.discharge_date## | List
##patientinpatientstay.admit_type## | List


Patient Procedures

Codes which list details of the procedures that a patient has had. Drawn from the same information as appears on the procedures screen for a patient in HeartSuite. You may wish to put the codes within a table to ensure that data lines up properly.
##procedures.description## | List
##procedures.ccad## | List of CCAD codes
##procedures.type## | List
##procedures.date_id## | List
##procedures.epc1## | List
##procedures.epc2## | List
##procedures.epc3## | List
##procedures.epc4## | List
##procedures.epc5## | List
##procedures.opcs4## | List
##procedures.location## | List


Surgery Cancelled For the Rest of the Month

Lists all of the Surgery for the rest of the month which was cancelled. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgcancelledrestmonth.date_id## | List of cancellation dates
##surgcancelledrestmonth.opdate## | List
##surgcancelledrestmonth.optime## | List of proposed operation times
##surgcancelledrestmonth.notes## | List of notes
##surgcancelledrestmonth.reason## | List of reasons for the cancellation
##surgcancelledrestmonth.revised_by## | List
##surgcancelledrestmonth.referred_by## | List
##surgcancelledrestmonth.operation## | List of proposed operation
##surgcancelledrestmonth.come_in## | List
##surgcancelledrestmonth.planned_op_date## | List
##surgcancelledrestmonth.blood_group## | List
##surgcancelledrestmonth.blood_quantity## | List
##surgcancelledrestmonth.scsr## | List
##surgcancelledrestmonth.suggested_procedure## | List
##surgcancelledrestmonth.condition## | List
##surgcancelledrestmonth.surgeon## | List
##surgcancelledrestmonth.shortprocedures_required## | List of the first 28 chars of procedures required
##surgcancelledrestmonth.procedure_types## |
##surgcancelledrestmonth.name## | List of patient names
##surgcancelledrestmonth.shortpdiagnosis## | List of primary diagnosis – first 25 chars
##surgcancelledrestmonth.dob## | List of dates of birth
##surgcancelledrestmonth.post_code## | List
##surgcancelledrestmonth.working_diagnosis## | List
##surgcancelledrestmonth.patient_id## | List of hospital numbers
##surgcancelledrestmonth.ward## | List


Surgery Cancelled Last Month

Lists all of the Surgery for last month which was cancelled. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgcancelledlastmonth.date_id## | List of cancellation dates
##surgcancelledlastmonth.opdate## | List
##surgcancelledlastmonth.optime## | List of proposed operation times
##surgcancelledlastmonth.notes## | List of notes
##surgcancelledlastmonth.reason## | List of reasons for the cancellation
##surgcancelledlastmonth.revised_by## | List
##surgcancelledlastmonth.referred_by## | List
##surgcancelledlastmonth.operation## | List of proposed operation
##surgcancelledlastmonth.come_in## | List
##surgcancelledlastmonth.planned_op_date## | List
##surgcancelledlastmonth.blood_group## | List
##surgcancelledlastmonth.blood_quantity## | List
##surgcancelledlastmonth.scsr## | List
##surgcancelledlastmonth.suggested_procedure## | List
##surgcancelledlastmonth.condition## | List
##surgcancelledlastmonth.surgeon## | List
##surgcancelledlastmonth.shortprocedures_required## | List of the first 28 chars of procedures required
##surgcancelledlastmonth.procedure_types## |
##surgcancelledlastmonth.name## | List of patient names
##surgcancelledlastmonth.shortpdiagnosis## | List of primary diagnosis – first 25 chars
##surgcancelledlastmonth.dob## | List of dates of birth
##surgcancelledlastmonth.post_code## | List
##surgcancelledlastmonth.working_diagnosis## | List
##surgcancelledlastmonth.patient_id## | List of hospital numbers
##surgcancelledlastmonth.ward## | List


Surgery Cancelled Next Month

Lists all of the Surgery for next month which was cancelled. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgcancellednextmonth.date_id## | List of cancellation dates
##surgcancellednextmonth.opdate## | List
##surgcancellednextmonth.optime## | List of proposed operation times
##surgcancellednextmonth.notes## | List of notes
##surgcancellednextmonth.reason## | List of reasons for the cancellation
##surgcancellednextmonth.revised_by## | List
##surgcancellednextmonth.referred_by## | List
##surgcancellednextmonth.operation## | List of proposed operation
##surgcancellednextmonth.come_in## | List
##surgcancellednextmonth.planned_op_date## | List
##surgcancellednextmonth.blood_group## | List
##surgcancellednextmonth.blood_quantity## | List
##surgcancellednextmonth.scsr## | List
##surgcancellednextmonth.suggested_procedure## | List
##surgcancellednextmonth.condition## | List
##surgcancellednextmonth.surgeon## | List
##surgcancellednextmonth.shortprocedures_required## | List of the first 28 chars of procedures required
##surgcancellednextmonth.procedure_types## |
##surgcancellednextmonth.name## | List of patient names
##surgcancellednextmonth.shortpdiagnosis## | List of primary diagnosis – first 25 chars
##surgcancellednextmonth.dob## | List of dates of birth
##surgcancellednextmonth.post_code## | List
##surgcancellednextmonth.working_diagnosis## | List
##surgcancellednextmonth.patient_id## | List of hospital numbers
##surgcancellednextmonth.ward## | List


Surgery Cancelled This Month

Lists all of the Surgery for this month which was cancelled. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgcancelledthismonth.date_id## | List of cancellation dates
##surgcancelledthismonth.opdate## | List
##surgcancelledthismonth.optime## | List of proposed operation times
##surgcancelledthismonth.notes## | List of notes
##surgcancelledthismonth.reason## | List of reasons for the cancellation
##surgcancelledthismonth.revised_by## | List
##surgcancelledthismonth.referred_by## | List
##surgcancelledthismonth.operation## | List of proposed operation
##surgcancelledthismonth.come_in## | List
##surgcancelledthismonth.planned_op_date## | List
##surgcancelledthismonth.blood_group## | List
##surgcancelledthismonth.blood_quantity## | List
##surgcancelledthismonth.scsr## | List
##surgcancelledthismonth.suggested_procedure## | List
##surgcancelledthismonth.condition## | List
##surgcancelledthismonth.surgeon## | List
##surgcancelledthismonth.shortprocedures_required## | List of the first 28 chars of procedures required
##surgcancelledthismonth.procedure_types## |
##surgcancelledthismonth.name## | List of patient names
##surgcancelledthismonth.shortpdiagnosis## | List of primary diagnosis – first 25 chars
##surgcancelledthismonth.dob## | List of dates of birth
##surgcancelledthismonth.post_code## | List
##surgcancelledthismonth.working_diagnosis## | List
##surgcancelledthismonth.patient_id## | List of hospital numbers
##surgcancelledthismonth.ward## | List


Surgery

Codes dealing with surgery. Relevant details for the surgical waiting list that goes with this surgery may also be accessed. Templates that use these codes must be tied to a specific procedure i.e. accessed through a button within the system.

Surgical Waiting List Codes Relating to the Surgery |
##surg.referral_date## |
##surg.referral_recieved## |
##surg.accepted_for_surgery## |
##surg.discharge_date## |
##surg.appointment_sent## |
##surg.come_in## |
##surg.planned_op_date## |
##surg.exit_from_wl## |
##surg.urg_revision_date## |
##surg.longreferral_date## | The following dates are displayed in a long form e.g. 15th March 2001
##surg.longreferral_recieved## |
##surg.longaccepted_for_surgery## |
##surg.longdischarge_date## |
##surg.longappointment_sent## |
##surg.longcome_in## |
##surg.longplanned_op_date## ##surg.longexit_from_wl## |
##surg.wlsurgeon## | The surgeon specified in the waiting list
##surg.patient_category## |
##surg.smrpatient_category## |
##surg.suggested_procedure## |
##surg.condition## |
##surg.blood_checked## |
##surg.teeth_inspection## |
##surg.ward## |
##surg.referral_letter## | Yes/No
##surg.surgery_performed## | Yes/No
##surg.scsr## |
##surg.caserefno## |
##surg.urgency## |
##surg.actual_urgency## |
##surg.smrurgency## |
##surg.smractual_urgency## |
##surg.previous_bypass## |
##surg.previous_closed## |
##surg.time_from_referral## |
##surg.procedure_required1## |
##surg.procedure_required2## |
##surg.smrprocedure_required1scs## |
##surg.smrprocedure_required2scs## |
##surg.blood_group## |
##surg.comment## |
##surg.comments## |
##surg.exit_reason## |
##surg.smrexit_reason## |
##surg.disposal## |
##surg.smrdisposal## |
##surg.surgery_where## | Specific to Birmingham
Surgery Details |
##surg.complications## | Lists complications and their comments
##surg.shortcomplications## | Lists complications
##surg.ccad_proc## | Lists procedure descriptions
##surg.ccad## | Lists all the European codes for the procedures
##surg.euro## | Lists all the European codes for the procedures
##surg.ccadpp## |
##surg.ccad_bypass## | Returns Bypass if complexity is greater than 1 else non-bypass
##surg.ccad_status## |
##surg.ccad_opgrade## |
##surg.preproc_seizures## |
##surg.postproc_seizures## |
##surg.repeat_procedure## |
##surg.repeat_incision## |
##surg.preproc_pcpc## |
##surg.postproc_pcpc## |
##surg.sternotomy_sequence## |
##surg.benchmark## |
##surg.prevproc_date_id## | Lists the dates of previous procedures
##surg.prevproc_description## | Lists the descriptions of previous procedures
##surg.prevproc_type## | Lists their types
##surg.prevproc_ccad## | Lists their CCAD codes
##surg.prevproc_euro## | Lists their euro codes
##surg.prevproc_ccadpp## | List
##surg.surgical_procedures## | Lists the surgical procedures done including SCS and complexity
##surg.smrsurgical_procedures## | Lists the surgical procedures
##surg.smrsurgical_proceduresscs## | Lists scs codes for the procedures done
##surg.smrsurgical_procedurescomp## | Returns the complexity of the primary procedure
##surg.smradditsurgical_procedures## | Get additional surgery from same waiting list if any
##surg.smradditsurgical_proceduresscs## | Get SCS codes for additional surgery from same waiting list if any
##surg.smradditsurgical_proceduresdate## | Get dates of additional surgery from same waiting list if any
##surg.shortsurgical_procedures## | Lists surgery done
##surg.date_id## | Date of surgery
##surg.height## |
##surg.weight## |
##surg.bsa## |
##surg.haem## |
##surg.reop_sequence## |
##surg.reop_text## |
##surg.surgeon## | Who did the surgery
##surg.smrsurgeon## | Returns their smr code
##surg.anaesthetist## |
##surg.assistant1## |
##surg.assistant1notes## | The notes in the staff record for assistant 1
##surg.assistant2## |
##surg.assistant2notes## | The notes in the staff record for assistant 2
##surg.diagnosis_notes## |
##surg.surgery_no## |
##surg.total_cpb_time## |
##surg.total_aoclamptime## |
##surg.total_circulatoryarrest_time## |
##surg.duration_ippv## |
##surg.cardiacdiagnosis## | Lists along with the ICD10 code for each
##surg.smrcardiacdiagnosis## |
##surg.smrcardiacdiagnosisicd10## | Lists along with the ICD10 code for each
##surg.shortcardiacdiagnosis## |
##surg.details## |
##surg.consultant## | The consultant responsible
##surg.type_of_procedure## |
##surg.postop_intubation## |
##surg.findings## |
##surg.intro## |
##surg.operation## |
##surg.incision## |
##surg.closure## |
Inpatient Details for this surgery |
##surg.admit_date## |
##surg.admit_consultant## |
##surg.discharge_consultant## |
##surg.itudays## |
##surg.hddays## |
##surg.warddays## |


Surgery for next month

Lists details for patients who have an operation date of next month. Data from their surgical waiting list may be accessed. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

##surgnextmonth.referred_by## | List
##surgnextmonth.operation## | List
##surgnextmonth.come_in## | List
##surgnextmonth.planned_op_date## | List
##surgnextmonth.blood_group## | List
##surgnextmonth.blood_quantity## | List
##surgnextmonth.scsr## | List
##surgnextmonth.suggested_procedure## | List
##surgnextmonth.condition## | List
##surgnextmonth.surgeon## | List
##surgnextmonth.shortprocedures_required## | List of the first 35 characters
##surgnextmonth.procedure_types## | List
##surgnextmonth.name## | List
##surgnextmonth.shortpdiagnosis## | List first 25 characters of the primary diagnosis
##surgnextmonth.dob## | List of date of births
##surgnextmonth.working_diagnosis## | List
##surgnextmonth.patient_id## | List of hospital numbers
##surgnextmonth.ward## | List


Surgery for the rest of the month

Lists details for patients who have an operation date during the rest of the month. Data from their surgical waiting list may be accessed. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

##surgrestmonth.referred_by## | List
##surgrestmonth.operation## | List
##surgrestmonth.come_in## | List
##surgrestmonth.planned_op_date## | List
##surgrestmonth.blood_group## | List
##surgrestmonth.blood_quantity## | List
##surgrestmonth.scsr## | List
##surgrestmonth.suggested_procedure## | List
##surgrestmonth.condition## | List
##surgrestmonth.surgeon## | List
##surgrestmonth.shortprocedures_required## | List of the first 35 characters
##surgrestmonth.procedure_types## | List
##surgrestmonth.name## | List
##surgrestmonth.shortpdiagnosis## | List first 25 characters of the primary diagnosis
##surgrestmonth.dob## | List of date of births
##surgrestmonth.working_diagnosis## | List
##surgrestmonth.patient_id## | List of hospital numbers
##surgrestmonth.ward## | List


Surgery for this month

Lists details for patients who have an operation date of this month. Data from their surgical waiting list may be accessed. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

##surgthismonth.referred_by## | List
##surgthismonth.operation## | List
##surgthismonth.come_in## | List
##surgthismonth.planned_op_date## | List
##surgthismonth.blood_group## | List
##surgthismonth.blood_quantity## | List
##surgthismonth.scsr## | List
##surgthismonth.suggested_procedure## | List
##surgthismonth.condition## | List
##surgthismonth.surgeon## | List
##surgthismonth.shortprocedures_required## | List of the first 35 characters
##surgthismonth.procedure_types## | List
##surgthismonth.name## | List
##surgthismonth.shortpdiagnosis## | List first 25 characters of the primary diagnosis
##surgthismonth.dob## | List of date of births
##surgthismonth.working_diagnosis## | List
##surgthismonth.patient_id## | List of hospital numbers
##surgthismonth.ward## | List


Surgery last month

Lists details for patients who have an operation date of last month. Data from their surgical waiting list may be accessed. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

##surglastmonth.referred_by## | List
##surglastmonth.operation## | List
##surglastmonth.come_in## | List
##surglastmonth.planned_op_date## | List
##surglastmonth.blood_group## | List
##surglastmonth.blood_quantity## | List
##surglastmonth.scsr## | List
##surglastmonth.suggested_procedure## | List
##surglastmonth.condition## | List
##surglastmonth.surgeon## | List
##surglastmonth.shortprocedures_required## | List of the first 35 characters
##surglastmonth.procedure_types## | List
##surglastmonth.name## | List
##surglastmonth.shortpdiagnosis## | List first 25 characters of the primary diagnosis
##surglastmonth.dob## | List of date of births
##surglastmonth.working_diagnosis## | List
##surglastmonth.patient_id## | List of hospital numbers
##surglastmonth.ward## | List


Surgical Discharges from last month

Codes that list details of all of the surgical discharges in the previous month. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgdischlastmonth.admit_date## | List
##surgdischlastmonth.patient_id## | List of hospital numbers
##surgdischlastmonth.discharge_date## | List
##surgdischlastmonth.length_of_stay## | List
##surgdischlastmonth.name## | List
##surgdischlastmonth.itustay## | List
##surgdischlastmonth.hddays## | List
##surgdischlastmonth.warddays## | List
##surgdischlastmonth.transfer## | List of dates of transfer from ICU back to ward
##surgdischlastmonth.pprocedures## | List of primary procedures during this stay
##surgdischlastmonth.opdate## | List of dates of surgery during this stay
##surgdischlastmonth.scsr## | List
##surgdischlastmonth.complexity## | List of surgery during this stay
##surgdischlastmonth.centre## | List
##surgdischlastmonth.date_of_death## | List of patients dates of death
##surgdischlastmonth.health_board## | List of patients health boards/authority's


Surgical Discharges from this month

Codes that list details of all of the surgical discharges so far this month. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgdischthismonth.admit_date## | List
##surgdischthismonth.patient_id## | List of hospital numbers
##surgdischthismonth.discharge_date## | List
##surgdischthismonth.length_of_stay## | List
##surgdischthismonth.name## | List
##surgdischthismonth.itustay## | List
##surgdischthismonth.hddays## | List
##surgdischthismonth.warddays## | List
##surgdischthismonth.transfer## | List of dates of transfer from ICU back to ward
##surgdischthismonth.pprocedures## | List of primary procedures during this stay
##surgdischthismonth.opdate## | List of dates of surgery during this stay
##surgdischthismonth.scsr## | List
##surgdischthismonth.complexity## | List of surgery during this stay
##surgdischthismonth.centre## | List
##surgdischthismonth.date_of_death## | List of patients dates of death
##surgdischthismonth.health_board## | List of patients health boards/authority's


Surgical Discharges from two months ago

Codes that list details of all of the surgical discharges two months ago. You may wish to put the codes within a table to ensure that data for each patient lines up properly.

##surgdisch2monthsago.admit_date## | List
##surgdisch2monthsago.patient_id## | List of hospital numbers
##surgdisch2monthsago.discharge_date## | List
##surgdisch2monthsago.length_of_stay## | List
##surgdisch2monthsago.name## | List
##surgdisch2monthsago.itustay## | List
##surgdisch2monthsago.hddays## | List
##surgdisch2monthsago.warddays## | List
##surgdisch2monthsago.transfer## | List of dates of transfer from ICU back to ward
##surgdisch2monthsago.pprocedures## | List of primary procedures during this stay
##surgdisch2monthsago.opdate## | List of dates of surgery during this stay
##surgdisch2monthsago.scsr## | List
##surgdisch2monthsago.complexity## | List of surgery during this stay
##surgdisch2monthsago.centre## | List
##surgdisch2monthsago.date_of_death## | List of patients dates of death
##surgdisch2monthsago.health_board## | List of patients health boards/authority's


Surgical Referral list

Lists details for patients on the Surgical Waiting List who do not yet have a come in and planned operation date. Data from their surgical waiting list may be accessed. You may wish to put the codes within a table to ensure that data for each consultation lines up properly.

To show active (i.e. not deferred)

##surgreflist.a:attended_clinic## | List – attended a pre op clinic yes or no
##surgreflist.a:attended## | List – attended a pre op clinic yes or no
##surgreflist.a:referral_date## | List
##surgreflist.a:blood_group## | List
##surgreflist.a:blood_quantity## | List
##surgreflist.a:scsr## | List
##surgreflist.a:surgeon## | List
##surgreflist.a:referred_to## | List
##surgreflist.a:comment## | List
##surgreflist.a:comments## | List
##surgreflist.a:procedures_required## | List
##surgreflist.a:procedure_types## | List
##surgreflist.a:suggested_procedure## | List
##surgreflist.a:condition## | List
##surgreflist.a:name## | List
##surgreflist.a:pdiagnosis## | List
##surgreflist.a:dob## | List
##surgreflist.a:centre## | List
##surgreflist.a:working_diagnosis## | List
##surgreflist.a:daysonwl## | List
##surgreflist.a:patient_id## | List of hospital numbers
##surgreflist.a:id## | List of hospital numbers
To show deferred |
##surgreflist.d:attended_clinic## | List – attended a pre op clinic yes or no
##surgreflist.d:attended## | List – attended a pre op clinic yes or no
##surgreflist.d:referral_date## | List
##surgreflist.d:blood_group## | List
##surgreflist.d:blood_quantity## | List
##surgreflist.d:scsr## | List
##surgreflist.d:surgeon## | List
##surgreflist.d:referred_to## | List
##surgreflist.d:comment## | List
##surgreflist.d:comments## | List
##surgreflist.d:procedures_required## | List
##surgreflist.d:procedure_types## | List
##surgreflist.d:suggested_procedure## | List
##surgreflist.d:condition## | List
##surgreflist.d:name## | List
##surgreflist.d:pdiagnosis## | List
##surgreflist.d:dob## | List
##surgreflist.d:centre## | List
##surgreflist.d:working_diagnosis## | List
##surgreflist.d:daysonwl## | List
##surgreflist.d:patient_id## | List of hospital numbers
##surgreflist.d:id## | List of hospital numbers
To show all |
##surgreflist.attended_clinic## | List – attended a pre op clinic yes or no
##surgreflist.attended## | List – attended a pre op clinic yes or no
##surgreflist.referral_date## | List
##surgreflist.blood_group## | List
##surgreflist.blood_quantity## | List
##surgreflist.scsr## | List
##surgreflist.surgeon## | List
##surgreflist.referred_to## | List
##surgreflist.comment## | List
##surgreflist.comments## | List
##surgreflist.procedures_required## | List
##surgreflist.procedure_types## | List
##surgreflist.suggested_procedure## | List
##surgreflist.condition## | List
##surgreflist.name## | List
##surgreflist.pdiagnosis## | List
##surgreflist.dob## | List
##surgreflist.centre## | List
##surgreflist.working_diagnosis## | List
##surgreflist.daysonwl## | List
##surgreflist.patient_id## | List of hospital numbers
##surgreflist.id## | List of hospital numbers


System Codes
Previous Top

These codes relate to general system information and may be used in any template.

##system.date## | Todays date in a long format
##system.shortdate## | Todays date in a short format
##system.longdate## | Todays date in the format dd/mmmm/ yyyy
##system.time## | The current date and time
##system.thismonth## | The current month
##system.nextmonth## | Next month
##system.lastmonth## | Last month
##system.2monthsagomonth## | What month it was two months ago
##system.thisyear## |
##system.nextmonthyear## | The year it will be next month
##system.lastmonthyear## | The year it was last month
##system.2monthsagoyear## | The year it was 2 months ago
##system.userid## | The current user's id
##system.username## | Of the current user
##system.userjobtitle## | Of the current user
##system.userinitials## | Of the current user
##system.usertelephone## | Of the current user
##system.useremail## | Of the current user
##system.userfax## | Of the current user
##system.version## | The version of HeartSuite being run
##system.hospital## | The hospital where the system is installed